Home > LINUX > How to install firefox to linux server?

How to install firefox to linux server?

April 8, 2012

Recently I supposed to upload some software to my server. During this activity I tried to download required software to my local PC and then tried to upload the same to server. But I felt this is not correct way since it is going to take long time. Later I found a way like install the firefox on the server then download the softeware directly to the server. Here wget is also not working due to security restrictions. I followed the following way.

1)      Login as root user and run the below command.

[root@rsvmsb344 ~]# yum search mozilla

Loaded plugins: security

certified                                                                                                                                                  |  951 B     00:00

certified/primary                                                                                                                                          | 1.6 MB     00:02

certified                                                                                                                                                             10298/10298

Excluding Packages in global exclude list

Finished

================================================================================ Matched: mozilla ================================================================================

bsf.x86_64 : Bean Scripting Framework

firefox.i386 : Mozilla Firefox Web browser.

firefox.x86_64 : Mozilla Firefox Web browser.

firefox-devel.i386 : Development files for Firefox

firefox-devel.x86_64 : Development files for Firefox

ldapjdk.x86_64 : The Mozilla LDAP Java SDK

ldapjdk-javadoc.x86_64 : Javadoc for ldapjdk

mozldap.x86_64 : Mozilla LDAP C SDK

mozldap-devel.i386 : Development libraries and examples for Mozilla LDAP C SDK

mozldap-devel.x86_64 : Development libraries and examples for Mozilla LDAP C SDK

mozldap-tools.x86_64 : Tools for the Mozilla LDAP C SDK

nspluginwrapper.i386 : A compatibility layer for Netscape 4 plugins

nspluginwrapper.x86_64 : A compatibility layer for Netscape 4 plugins

nspr.i386 : Netscape Portable Runtime

nspr.x86_64 : Netscape Portable Runtime

nspr-devel.i386 : Development libraries for the Netscape Portable Runtime

nspr-devel.x86_64 : Development libraries for the Netscape Portable Runtime

nss.i386 : Network Security Services

nss.x86_64 : Network Security Services

nss-devel.i386 : Development libraries for Network Security Services

nss-devel.x86_64 : Development libraries for Network Security Services

nss-pkcs11-devel.i386 : Development libraries for PKCS #11 (Cryptoki) using NSS

nss-pkcs11-devel.x86_64 : Development libraries for PKCS #11 (Cryptoki) using NSS

nss-tools.x86_64 : Tools for the Network Security Services

perl-Mozilla-LDAP.x86_64 : LDAP Perl module that wraps the Mozilla C SDK

pkinit-nss.x86_64 : PKINIT for MIT Kerberos

svrcore.i386 : Secure PIN handling using NSS crypto

svrcore.x86_64 : Secure PIN handling using NSS crypto

svrcore-devel.i386 : Development files for secure PIN handling using NSS crypto

svrcore-devel.x86_64 : Development files for secure PIN handling using NSS crypto

totem-mozplugin.x86_64 : Mozilla plugin for Totem

xulrunner.i386 : XUL Runtime for Gecko Applications

xulrunner.x86_64 : XUL Runtime for Gecko Applications

xulrunner-devel.i386 : Development files for Gecko

xulrunner-devel.x86_64 : Development files for Gecko

xulrunner-devel-unstable.x86_64 : Development files for Gecko, which are not considered stable

[root@rsvmsb344 ~]#

2)      Now run the install option for Mozilla. Using below command.

[root@rsvmsb344 ~]#yum install firefox.x86_64

Loaded plugins: security

Excluding Packages in global exclude list

Finished

Setting up Install Process

Resolving Dependencies

–> Running transaction check

—> Package firefox.x86_64 0:3.0.19-1.0.1.el5_5 set to be updated

–> Processing Dependency: xulrunner >= 1.9.0.19-1 for package: firefox

–> Running transaction check

—> Package xulrunner.x86_64 0:1.9.0.19-1.0.1.el5_5 set to be updated

–> Finished Dependency Resolution

 

Dependencies Resolved

 

==================================================================================================================================================================================

Package                                 Arch                                 Version                                               Repository                               Size

==================================================================================================================================================================================

Installing:

firefox                                 x86_64                               3.0.19-1.0.1.el5_5                                    certified                                12 M

Updating for dependencies:

xulrunner                               x86_64                               1.9.0.19-1.0.1.el5_5                                  certified                                11 M

 

Transaction Summary

==================================================================================================================================================================================

Install      1 Package(s)

Update       1 Package(s)

Remove       0 Package(s)

 

Total download size: 23 M

Is this ok [y/N]: Y

Downloading Packages:

(1/2): xulrunner-1.9.0.19-1.0.1.el5_5.x86_64.rpm                                                                                                           |  11 MB     00:12

(2/2): firefox-3.0.19-1.0.1.el5_5.x86_64.rpm                                                                                                               |  12 MB     00:14

———————————————————————————————————————————————————————————-

Total                                                                                                                                             844 kB/s |  23 MB     00:27

Running rpm_check_debug

Running Transaction Test

Finished Transaction Test

Transaction Test Succeeded

Running Transaction

Updating       : xulrunner                                                                                                                                                  1/3

Installing     : firefox                                                                                                                                                    2/3

Cleanup        : xulrunner                                                                                                                                                  3/3

 

Installed:

firefox.x86_64 0:3.0.19-1.0.1.el5_5

 

Dependency Updated:

xulrunner.x86_64 0:1.9.0.19-1.0.1.el5_5

 

Complete!

[root@rsvmsb344 ~]#

3)      Now start  the vnc server and connect to vnc server.  After connecting to VNC session (through any user), run the following command to open firefox browser.

$firefox

 

Now you will get the browser as per your requirement.

Advertisements
Categories: LINUX
%d bloggers like this: